Encontradas por el equipo de investigadores de Qualys

Detectan dos importantes vulnerabilidades en los sistemas operativos Linux

59
Linux
Linux

A pesar de que muchos defienden que los sistemas operativos de código abierto pueden resultar más seguros que los sistemas propietarios, algunas noticias pueden llegar a desmontar este argumento fácilmente. Es el caso de la que nos ocupa hoy. El equipo de investigadores de Qualys ha encontrado dos vulnerabilidades relevantes que afectan a sistemas operativos Linux.

La primera de ellas, nombrada como ‘Sequoia’ (CVE-201-33909), consistiría en una vulnerabilidad de escalada de privilegios en la capa del sistema de archivos de Linux. Se trata de una vulnerabilidad del tipo size_t-to-int en el sistema de archivos del Kernel de Linux, por lo que se ven afectados la mayoría de sistemas operativos.

Por la misma cualquier usuario sin privilegios tiene la posibilidad de obtener privilegios de administrador aprovechando esta vulnerabilidad en una configuración predeterminada.

Desde el equipo de investigación de seguridad de Qualys han comprobado la vulnerabilidad Sequoia de manera independiente, desarrollado un exploit y obtenido privilegios completos de administración en implementaciones predeterminadas de Ubuntu 20.04, Ubuntu 20.10, Ubuntu 21.04, Debian 11 y Fedora 34. No obstante, no descartan que otras distribuciones de Linux también resulten vulnerables en este sentido y eventualmente explotables.

La segunda vulnerabilidad afecta a Systemd

El proveedor de soluciones de cumplimiento y seguridad basadas en la nube también ha identificado la vulnerabilidad CVE-2021-33910. Esta sería una Denegación de Servicio del tipo stack exhaustion en Systemd (PID 1), una utilidad presente en la mayoría de sistemas operativos Linux.

De ser explotada, podría permitir que un usuario sin privilegios bloquee Systemd y, por tanto, todo el sistema operativo (kernel panic, o ataque del pánico del kernel).

Para detallar cómo funciona la vulnerabilidad Sequoia desde Qualys han publicado un detallado vídeo que se puede ver aquí.

Además, en el blog de la compañía explican los detalles técnicos sobre las dos vulnerabilidades con bastante detalle. Se puede pulsar pulsando en estos dos links:

https://blog.qualys.com/vulnerabilities-threat-research/2021/07/20/sequoia-a-local-privilege-escalation-vulnerability-in-linuxs-filesystem-layer-cve-2021-33909

https://blog.qualys.com/vulnerabilities-threat-research/2021/07/20/cve-2021-33910-denial-of-service-stack-exhaustion-in-systemd-pid-1

Artículo
Detectan dos importantes vulnerabilidades en los sistemas operativos Linux
Nombre
Detectan dos importantes vulnerabilidades en los sistemas operativos Linux
Descripcion
El equipo de investigadores de Qualys ha encontrado dos vulnerabilidades relevantes que afectan a sistemas operativos Linux.
Autor
Publico
Escudo Digital
Logo